Aide :Controler moteur MFA 950D

Discussions sur la fabrication, le génie mécanique et les matériaux.
Discussions on manufacturing, mechanical engineering, and materials.
Post Reply
Kriscox
Posts: 114
Joined: Fri 13 Jan 2006, 15:40

Aide :Controler moteur MFA 950D

Post by Kriscox » Mon 25 Jan 2016, 23:29

Bonjour,
j'utilise la shield adafruit v2 pour controler les moteurs d'un robot filoguidé avec la carte arduino
https://learn.adafruit.com/adafruit-mot ... or-arduino

Les moteurs sont des MFA 950D réduction 100:1
http://www.selectronic.fr/motoreducteur ... -1001.html

Quand je tourne droite gauche tout fonctionne, par contre quand je veux aller tout droit ou en arrière, les moteurs saccadent et ils font n'importent quoi.
J'ai essayé avec d'autres moteurs et cela fonctionne.
Je n'y comprends plus rien.
Quand j'essaie un seul moteur cela fonctionne aussi, c'est dès que je mets les deux.
Et les moteurs émettent un sifflement.
J'ai l'impression que le pont en H surchauffe, pourtant les moteurs ont un courant max de 1A et la carte peut accepter 1.2A par voie.
Si quelqu'un peut m'aider.
Merci
Image Image

Sandro
Posts: 17
Joined: Tue 02 Jun 2015, 11:15

Re: Aide :Controler moteur MFA 950D

Post by Sandro » Tue 26 Jan 2016, 15:21

Bonjour,
est-ce que tu as vérifier que le 1A des moteurs corresponde bien à la tension que tu leur applique (si tu as du 1A max en 6V, tu dépassera les 1.2V si tu mets du 9V par exemple). Fait aussi attention au fait que le courant max n'est pas le courant à vide (mais le courant bloqué).

Sinon, si tu veux tester si le problème vient d'une surconsommation des moteurs, il suffit de brancher un ampère-mètre en série et vérifier que tu ne dépasse pas les 1.2A

Vérifie aussi si ton shield autorise 1A/moteur en fonctionnement normal ou que en pointe (au démarrage, un moteur consomme plus qu'indiqué (problème qui est résolut par un condensateur de grosse capacité sur certains shields sauf erreur de ma part).

Vérifie aussi si ton alimentation est capable de fournir 2.5A (le 0.5A est pris au pif pour alimenter l'arduino et le shield, j'ai aucune idé combien ils consomment).


Désolé, c'est tout ce qui me vient à l'esprit, quelqu'un de plus compétant que moi pourra probablement mieux t'aider.

Bonne journée
Sandro

Keuronde
PMI
Posts: 500
Joined: Mon 25 Jan 2010, 22:48

Re: Aide :Controler moteur MFA 950D

Post by Keuronde » Tue 26 Jan 2016, 19:39

Ça peut aussi être un problème de perturbation électrique qui fait redémarrer le microcontrôleur.
C'est pas mal de rajouter une séquence reconnaissable au démarrage du microcontrôleur, comme faire clignoter une LED 3 à 4 fois.
Équipe Poivron
Coupe 2014 : Équipe Poivron (67e)
Coupe 2012 : Équipe Poivron (73e)
Coupe 2011 : Équipe Poivron (122e) - Prix des équipes !
Coupe 2010 : Équipe Poivron (78e)


Passez voir le Portail des équipes

Kriscox
Posts: 114
Joined: Fri 13 Jan 2006, 15:40

Re: Aide :Controler moteur MFA 950D

Post by Kriscox » Tue 26 Jan 2016, 21:59

Merci de votre aide. Mais rien de tout cela. Un foutu court circuit entre les fils des deux moteurs, du coup un court circuit sur le pont en H quand les moteurs tournaient en sens opposé. J'ai trouvé un peu par hasard, mais le principal c'est le résultat. Encore merci.
Image Image

Post Reply